Back to live map

CVE-2020-11023

KEVJQuery Cross-Site Scripting (XSS) Vulnerability

JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS 3.1 vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
PublishedApr 29, 2020
Last modifiedJun 17, 2026
Added to KEVJan 23, 2025
Remediation dueFeb 13, 2025
    73
    Risk assessment · High

    Actively exploited. Patch immediately.

    Exploitation
    Confirmed in the wild (CISA KEV)
    Federal remediation deadline
    Overdue by 621 days
    CVSS
    6.9 MEDIUM
    EPSS (30-day exploit probability)
    84.9% · top 1% of all CVEs
    Weakness
    CWE-79
    Attack vector
    Network, remotely reachable
    1. 1.Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
    2. 2.Treat as emergency change: patch or isolate internet-facing instances first.
    3. 3.Review exposure: confirm which instances are reachable from the internet and restrict access until patched.
    4. 4.Hunt for compromise: review logs for the disclosure window, not just from the patch date.

    Assessment is derived automatically from the live signals above; verify against your own asset inventory.