Back to live map

CVE-2024-38856

KEVApache OFBiz Incorrect Authorization Vulnerability

Apache OFBiz contains an incorrect authorization vulnerability that could allow remote code execution via a Groovy payload in the context of the OFBiz user process by an unauthenticated attacker.

Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

CVSS 3.1 vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
PublishedAug 5, 2024
Last modifiedJun 17, 2026
Added to KEVAug 27, 2024
Remediation dueSep 17, 2024
    89
    Risk assessment · Critical

    Actively exploited. Patch immediately.

    Exploitation
    Confirmed in the wild (CISA KEV)
    Federal remediation deadline
    Overdue by 771 days
    CVSS
    9.8 CRITICAL
    EPSS (30-day exploit probability)
    99.4% · top 1% of all CVEs
    Weakness
    CWE-863
    Attack vector
    Network, remotely reachable
    Preconditions
    No privileges and no user interaction
    1. 1.Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
    2. 2.Treat as emergency change: patch or isolate internet-facing instances first.
    3. 3.Review exposure: confirm which instances are reachable from the internet and restrict access until patched.
    4. 4.Hunt for compromise: review logs for the disclosure window, not just from the patch date.

    Assessment is derived automatically from the live signals above; verify against your own asset inventory.