Back to live map

CVE-2024-51567

KEVRansomware UseCyberPanel Incorrect Default Permissions Vulnerability

CyberPanel contains an incorrect default permissions vulnerability that allows a remote, unauthenticated attacker to execute commands as root.

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

CVSS 3.1 vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
PublishedOct 29, 2024
Last modifiedAug 4, 2026
Added to KEVNov 7, 2024
Remediation dueNov 28, 2024
    98
    Risk assessment · Critical

    Actively exploited and used by ransomware crews. Patch immediately.

    Exploitation
    Confirmed in the wild (CISA KEV)
    Federal remediation deadline
    Overdue by 699 days
    Ransomware
    Used in known ransomware campaigns
    CVSS
    10.0 CRITICAL
    EPSS (30-day exploit probability)
    84.4% · top 1% of all CVEs
    Weakness
    CWE-306
    Attack vector
    Network, remotely reachable
    Preconditions
    No privileges and no user interaction
    1. 1.Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
    2. 2.Treat as emergency change: patch or isolate internet-facing instances first.
    3. 3.Review exposure: confirm which instances are reachable from the internet and restrict access until patched.
    4. 4.Hunt for compromise: review logs for the disclosure window, not just from the patch date.
    5. 5.Verify offline/immutable backups and segment the affected systems. This flaw is used for ransomware initial access.

    Assessment is derived automatically from the live signals above; verify against your own asset inventory.