CVE-2025-24813
Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H- lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgqVendor Advisory
- openwall.com/lists/oss-security/2025/03/10/5Mailing ListThird Party Advisory
- lists.debian.org/debian-lts-announce/2025/04/msg00003.htmlMailing ListThird Party Advisory
- security.netapp.com/advisory/ntap-20250321-0001/Third Party Advisory
- vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rceIssue Tracking
- vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rceIssue Tracking
- vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerabilityIssue Tracking
- vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerabilityIssue Tracking
- github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.mdExploit
- cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813Third Party AdvisoryUS Government Resource
Actively exploited. Patch immediately.
- Exploitation
- Confirmed in the wild (CISA KEV)
- Federal remediation deadline
- Overdue by 552 days
- CVSS
- 9.8 CRITICAL
- EPSS (30-day exploit probability)
- 99.9% · top 1% of all CVEs
- Weakness
- CWE-44
- Attack vector
- Network, remotely reachable
- Preconditions
- No privileges and no user interaction
- 1.Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
- 2.Treat as emergency change: patch or isolate internet-facing instances first.
- 3.Review exposure: confirm which instances are reachable from the internet and restrict access until patched.
- 4.Hunt for compromise: review logs for the disclosure window, not just from the patch date.
Assessment is derived automatically from the live signals above; verify against your own asset inventory.